Jump to content


Photo

Thank you ASA for the great service


  • Please log in to reply
12 replies to this topic

#1 Giu

Giu

    Member

  • Members
  • 8 posts

Posted 05 May 2016 - 01:38 PM

Hi everybody, in December 2015 I sent my mount DDM85B to ASA due to a problem with the internal board. At the same to do a full service and upgrade the Absolute Encoder, at the same time I ordered a new fork mount for the bent pier: the reason being to use the 65kg. After four months the mount arrived and when I opened I found it was Father Christmas inside the box. ASA sent me a brand new mount DDM85X-A with all new connection leads. That's one of the best service I have expirienced in my life from any company. Thank you ASA and Thank you Dietmar for being so patient and helpful. Only this is I have to forget about the bent pier which I have already built.
Only this I notice is the com port is different from my previous mount, see attached image.
Attached File  image.jpeg   92.56KB   2 downloads
Does anyone else have this same port?

#2 MarkS

MarkS

    Member

  • Beta Tester
  • 410 posts
  • LocationMelbourne, Australia

Posted 05 May 2016 - 02:17 PM

Yes, I have a new DDM85A with that round com port.

 

Mine was supplied with a lead with a round plug at one end and USB at the other. In the lead there is an intermediate VGA style plug/socket with the electronic converter built in.

 

Regards,

Mark



#3 GeorgeCarey

GeorgeCarey

    Member

  • Beta Tester
  • 345 posts

Posted 05 May 2016 - 02:21 PM

Good to read a report from a happy customer. I also have had good service from ASA. Yes, it can sometimes take a while to get things going, but once a problem is identified ASA has sorted it out. My mount has been back to Austria more than once, and each time at no expense to me.

ASA DDM60Pro, homemade 8" and 10" reflectors, QSI 683 camera, Astrodon 5nm filters, Pulsar dome observatory. Website: http://www.geoastro.co.uk


#4 maxmirot

maxmirot

    Member

  • Beta Tester
  • 223 posts

Posted 05 May 2016 - 03:32 PM

Glad to hear it.

Besides USB and new encoders anything else new? How much did the upgrade cost ?

 

Max



#5 Giu

Giu

    Member

  • Members
  • 8 posts

Posted 05 May 2016 - 08:13 PM

Thanks Mark& George now I feel better, Giu

#6 Giu

Giu

    Member

  • Members
  • 8 posts

Posted 05 May 2016 - 08:23 PM

Hi, Max regards the cost is well worth I have more than one issues but instead they sent me the new mount, very sorry can't help you with the price you need contacts ASA best regards Giu

#7 maxmirot

maxmirot

    Member

  • Beta Tester
  • 223 posts

Posted 06 May 2016 - 05:00 AM

Thanks



#8 Denis Vien.

Denis Vien.

    Member

  • Members
  • 25 posts
  • LocationI live in Switzerland in the Jura Bure (je parle Français)

Posted 06 May 2016 - 08:12 AM

Hello everyone
It is really nice to hear that at ASA, the service is great, I will say thank you too, for the after sales service is very important to us direct drive mount User
Thank you
Denis



#9 Waldemar

Waldemar

    Member

  • Beta Tester
  • 242 posts
  • LocationNetherlands

Posted 06 May 2016 - 11:21 AM

I must say, I never had a bad experience with ASA... So I am absolutely not surprised about this, but it is very nice to hear.

I never had a bad experience with my DDM60Pro either, besides a failing USB hub... I just needed them for an upgrade and parts.

Especially Dietmar Weinzinger, who I dealt with a couple of times, is very service orientated and a great person to be in contact with.

 

just my 2 €c,

Waldemar


Waldemar
--------------
Mount: DDM85 Standard 12V ; Telescopes: TEC140 + 140FF + Quad TCC ; Celestron RASA; TMB 92SS + 27TVPH Cameras: ZWO ASI 174MM cool; SBIG STF8300M; ATIK4120EX; TRIUS SX-36
Filters: Astronomik and Baader NB + RGB; Lunt double stack 75 mm unobstructed signature series + BF 3400; Dutch weather and light polluted skies.  

#10 MarkS

MarkS

    Member

  • Beta Tester
  • 410 posts
  • LocationMelbourne, Australia

Posted 08 May 2016 - 02:34 AM

As I have already said elsewhere, I too have always had excellent service from ASA.

 

Mark



#11 maxmirot

maxmirot

    Member

  • Beta Tester
  • 223 posts

Posted 09 May 2016 - 03:05 PM

I glad others are getting help.

Still waiting for a email response from ASA to a service request and upgrade questions sent 2x times last week.

I emailed support@asa.... and individual email to ASA team member.

  Checked my spam folder too. I hope there is a technical reason my emails are not getting through.

 

How long do you have to wait for a email response ?

 

Should I call Germany?  Please give me Dietmar's email.

 

Max



#12 nakbrooks

nakbrooks

    Member

  • Beta Tester
  • 268 posts
  • LocationWiltshire (England) & Hautes-Pyrenees (France)

Posted 09 May 2016 - 05:30 PM

Dietmar is in Austria. Email is d.weinzinger@astrosysteme.at although the support email is the official one to use.

I also have had excellent service - although if the documentation were better it would reduce the need for service calls.
Nigel Brooks
Stratis Observatory, Hautes Pyrénées, France.
http://www.facebook.com/stratisobservatory

#13 maxmirot

maxmirot

    Member

  • Beta Tester
  • 223 posts

Posted 09 May 2016 - 07:06 PM

Dietmar,

 

Just got back to me.  Apparently, May is a big holiday month in Germany.

 

One things I asked about was when will the DDM85 get its own computer. 

 

He said they hope to have this offered by years end.

I think this would be really great if it is hard wired ( no more USB).






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users